DonNash

Battleye Issue/Bug

Recommended Posts

DonNash    0

Reto,fix this problem asap !!! It's your fault !!! Battle eye or not battle eye but it's your task to fix it! Windows is licence,all sysyems,files etc are ok !!! all checked -nothing wrong,so

it's only because of your last changes...I payed money and I cannot use it !

Share this post


Link to post
Share on other sites
T0UCH010    0

So i have been having this battleye issue for the past 3 days and i can't find a solution. This issue occurs when i get in a match on any map.I wait for it to start maybe start running or driving around and it "crashes", sometimes it does not even let me spawn and displays a message: "An issue occurred. BattlEye Anti-Cheat protection requests that you please restart the game." I really need your guys help because i really love this game and don't want to let it go like that.

 

Edit: I have tried the standalone version still didn't work, run it as administrator still nothing...

 

please help.

Edited

Share this post


Link to post
Share on other sites
GozerBCN    16

Hello,

Same error here, as I reported a few days ago. I can play for a few seconds then the message pops up and I get kicked from the battle.

I updated my Geforce GTX 680 drivers to the last version, tried reinstalling the game, closed all programs, etc. None of that worked.

 I contacted BattlEye and they replied with a generic FAQ, which seems ridiculous.

 

A little help setting BattlEye or H&G on debug mode with a message screen with what went wrong, because the message we receive from BattlEye is far from helpful.

Share this post


Link to post
Share on other sites
T0UCH010    0
2 hours ago, GozerBCN said:

Hello,

Same error here, as I reported a few days ago. I can play for a few seconds then the message pops up and I get kicked from the battle.

I updated my Geforce GTX 680 drivers to the last version, tried reinstalling the game, closed all programs, etc. None of that worked.

 I contacted BattlEye and they replied with a generic FAQ, which seems ridiculous.

 

A little help setting BattlEye or H&G on debug mode with a message screen with what went wrong, because the message we receive from BattlEye is far from helpful.

Yeah... I have been researching for the past hour and still can't find a fix.

Thanks for the reply.

Share this post


Link to post
Share on other sites
QuarX    318
1 hour ago, T0UCH010 said:

Yeah... I have been researching for the past hour and still can't find a fix.

Thanks for the reply.

You were Kicked off the game (Battleye: Game restart required)
This is happening because you permanently declined BE installation by clicking “Do not ask me again.” in the BE Launcher window previously.

To fix this please go to the “BattlEye” folder in your game directory....

Stand-Alone version:

C:\Program Files (x86)\Heroes & Generals\live\BattlEye

Steam vserion:

C:\Program Files (x86)\Steam\steamapps\common\Heroes & Generals\BattlEye

...and double-click the “Install_BattlEye.bat” file to install BE

Share this post


Link to post
Share on other sites
T0UCH010    0
2 hours ago, QuarX said:

You were Kicked off the game (Battleye: Game restart required)
This is happening because you permanently declined BE installation by clicking “Do not ask me again.” in the BE Launcher window previously.

To fix this please go to the “BattlEye” folder in your game directory....

Stand-Alone version:

C:\Program Files (x86)\Heroes & Generals\live\BattlEye

Steam vserion:

C:\Program Files (x86)\Steam\steamapps\common\Heroes & Generals\BattlEye

...and double-click the “Install_BattlEye.bat” file to install BE

So.... i've done that all correctly... but... it still dosen't work. The same message pops up immidiately or after i join a match...

Share this post


Link to post
Share on other sites
QuarX    318
2 minutes ago, T0UCH010 said:

So.... i've done that all correctly... but... it still dosen't work. The same message pops up immidiately or after i join a match...

UUhh ... maybe close the game client and run the uninstall.bat in the same directory first and then run the install.bat ?

All I know so far about Battleye is that this kind of behavior happens when Battleye has trouble to initialize itself.

 

Share this post


Link to post
Share on other sites
QuarX    318
26 minutes ago, T0UCH010 said:

So.... i've done that all correctly... but... it still dosen't work. The same message pops up immidiately or after i join a match...

Another reason might be if you're using Steam version and starting the game via its own icon.

Please try to start the game from the Steam library instead.

Share this post


Link to post
Share on other sites
T0UCH010    0
15 hours ago, QuarX said:

UUhh ... maybe close the game client and run the uninstall.bat in the same directory first and then run the install.bat ?

All I know so far about Battleye is that this kind of behavior happens when Battleye has trouble to initialize itself.

 

 

14 hours ago, QuarX said:

Another reason might be if you're using Steam version and starting the game via its own icon.

Please try to start the game from the Steam library instead.

Tried both things and still shows the message. 1 thing the game works perfectly fine without problems on the prototype version. What if i reinstall heroes and generals all togeheter?

Edited

Share this post


Link to post
Share on other sites
QuarX    318
1 minute ago, T0UCH010 said:

 

Tried both things and still shows the message. What if i reinstall heroes and generals all togeheter?

Well, I don't think that this will do the trick :/

Do you use a Antivirus security suite on your computer that may block/sandbox Battleye ?

If so make sure that you tell that Antivirus that Battleye is a "trusted application"

Share this post


Link to post
Share on other sites
T0UCH010    0
11 minutes ago, QuarX said:

Well, I don't think that this will do the trick :/

Do you use a Antivirus security suite on your computer that may block/sandbox Battleye ?

If so make sure that you tell that Antivirus that Battleye is a "trusted application"

No worries i fixed it.

I basically copied the battleye files from the prototype version to the steam version and now it works.

Thanks for the replies

Share this post


Link to post
Share on other sites
GozerBCN    16

EDITED:

 

*****************PARTIALLY SOLVED THEN CRASHED AFTER REBOOT***********************

 

As Touch010 said I managed to download and install the Prototype (http://prototype.heroesandgenerals.com), deinstalled BattlEye (using "Uninstall_BattlEye.bat" in H&G folder), deleted "C:\Program Files (x86)\Common Files\BattlEye" folder, copied "BattlEye" folder contents from H&G Prototype to H&G.

On first run it asked me to install BattlEye as resident: did so. I first got a network sync error after a few minutes playing, but now it seems to work ok.

 

 

**************************************************

Ok,

I will try the prototype files solution and let you know.

 

So far I've tried:

- Reinstalling H&G Steam client and deleting the entire H&G and BattlEye folders.

- H&G Standalone Client (no steam).

- Running the "Install_BattlEye.bat" as admin.

- Running the "Uninstall_BattlEye.bat" as admin and relaunching H&G Steam Client (it ask to set BattlEye protection again on first launch)

- Setting H&G Steam client to windowed mode with low resolution.

- Updating W7.

- Updating Nvidia GTX680 drivers via Geforce Experience to the last version.

- Contacting BattlEye for support (they told me to read the FAQ...)

- Opening a ticket to H&G support to report that.

- Deleted "C:\Program Files (x86)\Common Files\BattlEye" and relaunched the game.

 

EDIT: Well, I tried to access the prototype url at "http://prototype.heroesandgenerals.com/" but it won't load. Splendid, this is getting better every minute.

Edited

Share this post


Link to post
Share on other sites

Problem appears only on the pirate Windows. It's not a virus, malware, Secret World Government or else. It's a pirate Windows, which has been activated with a some crack software. BattlEye is just comparing checksum of system files and blocking access if they're not matching.

Share this post


Link to post
Share on other sites
QuarX    318
15 hours ago, Robot_Bandera said:

Problem appears only on the pirate Windows. It's not a virus, malware, Secret World Government or else. It's a pirate Windows, which has been activated with a some crack software. BattlEye is just comparing checksum of system files and blocking access if they're not matching.

I think you're right .. besides using a pirated copy of Windows online would be unbelievably stupid... script kiddies these days xD

Share this post


Link to post
Share on other sites
GozerBCN    16
On 5/6/2018 at 12:04 PM, QuarX said:

I think you're right .. besides using a pirated copy of Windows online would be unbelievably stupid... script kiddies these days xD

 

Not in my case, as my W7 is legal. Copying BattlEye files from the Prototype version worked fine. Something is wrong with the 'stable' release.

Share this post


Link to post
Share on other sites
QuarX    318
7 minutes ago, GozerBCN said:

Not in my case, as my W7 is legal. Copying BattlEye files from the Prototype version worked fine. Something is wrong with the 'stable' release.

Well, if there would be a problem with the version of Battleye on the live server this forum would be on fire.^_^

Battleye is just a piece of binary code (made by humans) and it can fail.

 

Share this post


Link to post
Share on other sites
GozerBCN    16
On 6/6/2018 at 11:18 PM, QuarX said:

Well, if there would be a problem with the version of Battleye on the live server this forum would be on fire.^_^

Battleye is just a piece of binary code (made by humans) and it can fail.

 

 

Mmmm kinda looks like wolverine XDDDD

Share this post


Link to post
Share on other sites
GozerBCN    16
On 6/6/2018 at 11:18 PM, QuarX said:

Well, if there would be a problem with the version of Battleye on the live server this forum would be on fire.^_^

Battleye is just a piece of binary code (made by humans) and it can fail.

 

 

Well, after a restart I got the BattlEye issue again. Kicks me out of the mission without reason. Just says BattlEye needs the game to be restarted.

Any chance I can send RETO a dump or set BattlEye in debug mode to show on screen why it crashes?

 

Not getting the Kernel Mod issue. Game starts but says "BattlEye needs the game to be restarted". No BattlEye popups or crash logs.

Share this post


Link to post
Share on other sites
QuarX    318
4 hours ago, GozerBCN said:

Well, after a restart I got the BattlEye issue again. Kicks me out of the mission without reason. Just says BattlEye needs the game to be restarted.

Any chance I can send RETO a dump or set BattlEye in debug mode to show on screen why it crashes?

The problem is that people/players need to understand that >> BattlEye << is not a Reto product!!

Reto can only give very limited support on it

Their job is, to insure a flawless implementation of BattlEye into their product/game.

 

About your issue:

"BattlEye needs the game to be restarted" this message means, that the game server can not detect or connect to an valid BattlEye installation on your computer.

This is happening because you permanently declined BattlEye installation by clicking “Do not ask me again.” in the BattleEye Launcher window previously.

To fix this please go to the “BattlEye” folder in your game directory and double-click the “Install_BattlEye.bat” file to install BattlEye.

 

A good read about this kind of problems.

https://heroesandgenerals.com/support/battleye/battleye-fails-to-install-start/

 

 

Share this post


Link to post
Share on other sites
GozerBCN    16
4 hours ago, QuarX said:

The problem is that people/players need to understand that >> BattlEye << is not a Reto product!!

Reto can only give very limited support on it

Their job is, to insure a flawless implementation of BattlEye into their product/game.

 

About your issue:

"BattlEye needs the game to be restarted" this message means, that the game server can not detect or connect to an valid BattlEye installation on your computer.

This is happening because you permanently declined BattlEye installation by clicking “Do not ask me again.” in the BattleEye Launcher window previously.

To fix this please go to the “BattlEye” folder in your game directory and double-click the “Install_BattlEye.bat” file to install BattlEye.

 

A good read about this kind of problems.

https://heroesandgenerals.com/support/battleye/battleye-fails-to-install-start/

 

 

 

Not my case, as I stated before a few messages ago (jun 3 edited post). Something's wrong between BattlEye and H&G. The service is running (for example now on PID 1300) and still I get the message.

 

As a former programmer I understand BattlEye is a third party product, and its issues have to be handled by the BE crew, but the issue is deeply related with H&G not able to communicate with the BE daemon, so AFAIK BOTH companies should look into it.

Not asking about a custom solution for my problem, but a little interest in at least asking me for logs or replying with something else than the cut'n'paste autoreply would be appreciated.

 

Share this post


Link to post
Share on other sites