Reto.Robotron3000

Hotfix for Performance Issue released today

Recommended Posts

Reto.Robotron3000    1,118

We've found and fixed a bug that caused a drop in framerate for some players.


The bug was introduced in 1.07.1 and has been fixed in a hotfix today (16AUG17).

 

IF you still experience a lower framerate than before 1.07 please post in the bug hunter forum so we can gather the necessary information to get it fixed. 

 

For those interested the bug was related to a number of compiler flags generating code that ran slower on some machine configurations. 

 

YAY! Smash teh bugs :D

Share this post


Link to post
Share on other sites
Ted.The.Bear    82
1 hour ago, Reto.Robotron3000 said:

We've found and fixed a bug that caused a drop in framerate for some players.


The bug was introduced in 1.07.1 and has been fixed in a hotfix today (16AUG17).

 

IF you still experience a lower framerate than before 1.07 please post in the bug hunter forum so we can gather the necessary information to get it fixed. 

 

For those interested the bug was related to a number of compiler flags generating code that ran slower on some machine configurations. 

 

YAY! Smash teh bugs :D

 

Its fixed :) good job

 

Somehow it worked for me:

I went from low settings (60-80 fps)

back to high settings (90+ fps)

Edited

Share this post


Link to post
Share on other sites
Mastah    1,139

Credits where credits due, so good job on this one.

 

However, still a long way to go to get Heroes & generals ™ back on its old tracks

Share this post


Link to post
Share on other sites
Jacky95    2,351

well..I still get Moscov server all day since yesterday so it really does not matter to me.........P.S I live in Hungary and never before had to play on Moscov server....

 

The +funny thing is, right after the new build got released my fps went above 40 fps reaching 60..but than was some hotfix so iam back to the regular 25-40 fps...iam not bitc.hing, but am just curious how it went up that high and then went back to bad.

Edited

Share this post


Link to post
Share on other sites
Reto.Robotron3000    1,118
5 minutes ago, Jacky95 said:

well..I still get Moscov server all day since yesterday so it really does not matter to me.........P.S I live in Hungary and never before had to play on Moscov server....

 

The +funny thing is, right after the new build got released my fps went above 40 fps reaching 60..but than was some hotfix so iam back to the regular 25-40 fps...iam not bitc.hing, but am just curious how it went up that high and then went back to bad.

weird, but not related. Please post in the bug hunters section for each of these two issues so we can dig into them, get reproduction set up, and get it fixed. 

Share this post


Link to post
Share on other sites
Paciencia095    247

Still having the same issues if not actually worse, isnt there a way to request a refund or something until the game is fixed? This isnt tolerable, game runs like crap and my rig is more than capable of move this game over 60fps. Totally unplayable when the game is stuttering every few seconds, asking for gold while having this issues on the game really fed me up.

 

Edit:

Ryzen 5 1600 3.9ghz

Rx 480

G. skill flare x 3200mhz

 

 

Edited

Share this post


Link to post
Share on other sites
Lemarcq    46

goodjob on the fast fix? 

 

not sure if thats fast or not but if it is fixed it is fixed nothing bad to say about that :)

Share this post


Link to post
Share on other sites
Champi0n    433

Good to see the performance fix! Yet to test it out tho.

Post reserved for feedback :P

Share this post


Link to post
Share on other sites
Paciencia095    247
6 minutes ago, DeinGottAnubis- said:

man you guys have crappy computers. I got 240 fps (high settings) on Forward Airfield.

I can look to the sky and get 300fps too that doesnt means the game isnt broken. It stutters because releasing a mess of update that still a month after it its not fixed, for release such a mess of update better to not release anything, hng isnt anymore on early access so this kind of stuff, the game being unplayable for weeks is not tolerable on any way.

Share this post


Link to post
Share on other sites
HitnRun2016    906
1 hour ago, Reto.Robotron3000 said:

weird, but not related. Please post in the bug hunters section for each of these two issues so we can dig into them, get reproduction set up, and get it fixed. 

Are you seriuosly telling us that Reto are not aware of the performance issues for players outside of Russia playing on the Russian server? There has been about 1 million posts about it!

Share this post


Link to post
Share on other sites
Evilspace    20

Yea its fixed for me and a mate too.

Finaly, thanks!

 

giphy.gif

 

PS: Lets hope that will last longer then the next patch :D

Share this post


Link to post
Share on other sites
Reto.Robotron3000    1,118
36 minutes ago, HitnRun2016 said:

Are you seriuosly telling us that Reto are not aware of the performance issues for players outside of Russia playing on the Russian server? There has been about 1 million posts about it!

I (as in me personally) was not aware that there is an issue with players getting sent to servers with high ping, unless MM had issues finding battles for your filter settings within a reasonable time. Also as I am deep in Leaderboard bug-fixing land I did not go and ask anyone else before posting. 

 

Share this post


Link to post
Share on other sites
HitnRun2016    906
1 minute ago, Reto.Robotron3000 said:

I (as in me personally) was not aware that there is an issue with players getting sent to servers with high ping, unless MM had issues finding battles for your filter settings within a reasonable time. Also as I am deep in Leaderboard bug-fixing land I did not go and ask anyone else before posting. 

 

Its not really a ping issue as such, the ping for me is a stable 80 but opposition players are teleporting everywhere, the hit registery is way off, its like playing with bad ping but you aren't its really odd. 

Share this post


Link to post
Share on other sites
AfonsoQQ    3,009

I used to get 120  FPS in town back in january, then it dropped to 60, now its back to 90, not bad.

But please get rid of the goddamn bush spam, theyr bad for both preformance and gameplay.

5 minutes ago, Reto.Robotron3000 said:

I (as in me personally) was not aware that there is an issue with players getting sent to servers with high ping, unless MM had issues finding battles for your filter settings within a reasonable time. Also as I am deep in Leaderboard bug-fixing land I did not go and ask anyone else before posting. 

 

The problem with the Russian server isnt the ping, its how slow it is, i have stuttering and non registering hits all the time on that godamn server.

Share this post


Link to post
Share on other sites
WarDaemon    1,186
17 minutes ago, Reto.Robotron3000 said:

I (as in me personally) was not aware that there is an issue with players getting sent to servers with high ping, unless MM had issues finding battles for your filter settings within a reasonable time. Also as I am deep in Leaderboard bug-fixing land I did not go and ask anyone else before posting. 

 

 

Agreed, I'm US east coast and I'd rather play 240 Asia ping than play 165 Moscow ping because it's weird and sticky, I feel like I'm fighting my way through pudding.

Share this post


Link to post
Share on other sites
meforte    99
2 minutes ago, WarDaemon said:

 

pudding

mmm, now all i want is pudding..  In other news, gj on the fps lag fix @reto.moto

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.