Bob-the-Builder

Sudden FPS Drops

Recommended Posts

I am using above recommended hardware with nothing else running on my computer. About once every 30 seconds my frame rate drops from 35 to 10 for 3 seconds. When I first played this game 3 years ago I had zero FPS drops until a client update happened (Years Ago). The game severely annoying to play with such constant FPS drops. Either increase the recommended hardware or fix the FPS drop issue.

Edited

Share this post


Link to post
Share on other sites
HarmlessHarry    335

The GeForce 635 integrated graphics chip is the problem.  This game has become more hardware demanding and your 635 is not up for the job anymore. To be more specific, it sounds like your graphics chip 635 is running out of Vram at times.  Depending on your location on the map, or combat situation (explosions/action, etc), your Vram on the 635 is exceeded, causing the intermittent FPS drops.  This means that your computer needs to pull data/information from your memory or even the hard drive, which is massively slower than the Vram in GPU's (Graphic Cards).

Share this post


Link to post
Share on other sites
1 hour ago, HarmlessHarry said:

The GeForce 635 integrated graphics chip is the problem.  This game has become more hardware demanding and your 635 is not up for the job anymore. To be more specific, it sounds like your graphics chip 635 is running out of Vram at times.  Depending on your location on the map, or combat situation (explosions/action, etc), your Vram on the 635 is exceeded, causing the intermittent FPS drops.  This means that your computer needs to pull data/information from your memory or even the hard drive, which is massively slower than the Vram in GPU's (Graphic Cards).

The 635m has 2 gb of VRAM (which is well above the 512mb minimum spec listed on steam) so I tested you're suspicions. I took a screenshot of hardware usage during a game with FPS drops.

 

https://imgur.com/a/G0gaI

 

I first noted that of the 2gb of VRAM only a steady 1.2gb was being used throughout the entire match. The GPU load was consistently maxed but still provided ~40 fps. The thread(s) running the game were maxed while yielding a consistant framerate. The oddity found is that when CPU usage decreases from 100% to 50% the FPS drop occurs. I confirmed that with 10 FPS drops each one had a parallel drop in CPU usage. 

 

So, why is CPU usage dropping for 2 seconds then rising immediately? Note that I've played many other games such as Dota 2, Warthunder, World of Tanks and Skyrim which are similarily demanding. In none of those games I experience inconsistent FPS.

 

Due to the above, I'm inclined to believe this is not a problem with my hardware or configuration, but of something regarding Heroes and Generals.

Share this post


Link to post
Share on other sites
HarmlessHarry    335
On 6/27/2017 at 11:54 AM, Bob-the-Builder said:

The 635m has 2 gb of VRAM (which is well above the 512mb minimum spec listed on steam) so I tested you're suspicions. I took a screenshot of hardware usage during a game with FPS drops.

 

https://imgur.com/a/G0gaI

 

I first noted that of the 2gb of VRAM only a steady 1.2gb was being used throughout the entire match. The GPU load was consistently maxed but still provided ~40 fps. The thread(s) running the game were maxed while yielding a consistant framerate. The oddity found is that when CPU usage decreases from 100% to 50% the FPS drop occurs. I confirmed that with 10 FPS drops each one had a parallel drop in CPU usage. 

 

So, why is CPU usage dropping for 2 seconds then rising immediately? Note that I've played many other games such as Dota 2, Warthunder, World of Tanks and Skyrim which are similarily demanding. In none of those games I experience inconsistent FPS.

 

Due to the above, I'm inclined to believe this is not a problem with my hardware or configuration, but of something regarding Heroes and Generals.

 

Interesting, I didn't think that integrated chip had 2 GB of memory.  Regardless, you should be able to play on low settins/low resolution at a steady 30+ FPS.

 

Well something is up with your CPU with this game then.  How are the temps?

 

Note, my older CPU would give me fits at times with this game when it got too hot, or its usage was nearly 100%.  That was an AMD Phenom II X4 955.  It benchmarks slightly over your processor.  I upgraded to an I7 and I no longer had heat or usage problems.

 

Is Turbo Boost an option for you?  Does High Performance mode make any difference?

Edited

Share this post


Link to post
Share on other sites
Kmeto    717

Keep monitoring your CPU usage. When it hits 100% game stutters. I have way way way stronger processor than you and still it can't handle H&G well.

On 6/27/2017 at 8:54 PM, Bob-the-Builder said:

In none of those games I experience inconsistent FPS.

Me same. It's just H&G. Reto can't make video games.

Share this post


Link to post
Share on other sites
dexter1984    675
On 6/27/2017 at 8:54 PM, Bob-the-Builder said:

The 635m has 2 gb of VRAM (which is well above the 512mb minimum spec listed on steam) so I tested you're suspicions. I took a screenshot of hardware usage during a game with FPS drops.

 

https://imgur.com/a/G0gaI

 

I first noted that of the 2gb of VRAM only a steady 1.2gb was being used throughout the entire match. The GPU load was consistently maxed but still provided ~40 fps. The thread(s) running the game were maxed while yielding a consistant framerate. The oddity found is that when CPU usage decreases from 100% to 50% the FPS drop occurs. I confirmed that with 10 FPS drops each one had a parallel drop in CPU usage. 

 

So, why is CPU usage dropping for 2 seconds then rising immediately? Note that I've played many other games such as Dota 2, Warthunder, World of Tanks and Skyrim which are similarily demanding. In none of those games I experience inconsistent FPS.

 

Due to the above, I'm inclined to believe this is not a problem with my hardware or configuration, but of something regarding Heroes and Generals.

Upgrade you PC !!!

Share this post


Link to post
Share on other sites
drkfrontiers    284

Terrible server experience these last few weeks. Laggy and all round cr@p. Sigh

 

And whats worse is the bitter reality that they will do nothing about it.

Share this post


Link to post
Share on other sites
[5150]Rasputin    307

I've been having no FPS issues with H&G this past week.  I have had problems with spiking ping rates... from 15 ping it shoots to 200+ when entering forests/forested area... and then returns back to 15 or so FPS after a couple seconds.  This routinely causes screen stutters and negatively hampers gameplay  (as I move around the map).

 

To the OP, please be aware many H&G players report similar problems with this game but some of them attribute it to this game's unresolved coding issues.

Edited

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a free game account. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now