Reto.Hades

Not earning experience

Recommended Posts

Reto.Hades    3,436

Hello everyone,

 

We are noticing a lot of topics from players not earning experience at all after a battle, or missing experience on their ribbons.

In order for us to investigate this further, we are looking for your help.

 

Please create a reply in this topic, with the following information:

 

- Affected character

- Affected ribbon(s)

- When a certain ribbon has been affected (f.e.x. tank destruction) please also note down which vehicle/weapon was used and with what ammotype.

- A screenshot of the scoreboard

- BattleID (Click the topic below to see how you can find the battleID)

 

Thank you for your help and we hope to be able to fix this bug as soon as possible!

Share this post


Link to post
Share on other sites
Haiw    300

-Affects all my characters across the board when it happens 

-Affects all ribbons when it happens

-Sorry don't have screenshots or battleIDs.

-The problem started occuring after the last hotfix

 

What tends to happen is that everything shows up as it should in the scoreboard, XP, ribbons, money, promotions and everything. Except after you close the screen none of it is actually added to the characters. Oddly enough, it does not affect the credits or warfunds. Credits & warfunds are earned as they should, and repairs are deducted in the normal fashion.

It currently seems to happen to most, or almost all war battles for me. It also occurs in staged battles, although a lot less. Since I mostly played encounter-style battles to grind some ribbons, it could be related to battle length. Some longer staged battles had the same problem.

 

I'm a bit surprised this only seems to pop up on the radar know. It seems like everyone has this problem, even though many might simply not notice it. It took a while for me to notice as well.

Share this post


Link to post
Share on other sites
Jmj191    1,029

Gonna try and explain to you the ribbon XP bugs that have been occurring. In the first screenshot which is after a battle has occurred it shows that i should have grease gun specialist gold 2 which it gives you the in battle advance of the ribbon and after the match shows the mod/mods which you've unlocked and you can purchase/use them yet when you look at the second screenshot which is the same soldier just in the next unlocks section it shows that i have grease gun specialist gold 1 which it actually registers that as to being what i have but it allows me to buy the mods that i just unlocked. Not only that though i have to regrind the XP that hasn't registered to get back to gold specialist 2 and then to gold specialist 3 respectively. Which is the main issue currently as some games it does register the xp for the ribbons and other times it does this same bug where if you unlocked the next ribbon during the game you can use the mods/unlocks you got yet you will have to regrind that xp to get back to those mods/where you should already be. I hope this helps with some insight into the issue also note this was before April 7s hot fix and this occurred after the 2 hot fixes before as well.

.f04f5b313889447b972e3a3711437c82.png

 1aa2efa4094247ad9b95ec8f547dc1ec.png

Update: When i just logged in now i got a lot of XP on some of the ribbons although i haven't played in the last 2 days since these screenshots. This Does not include any soldier XP though.

Edited

Share this post


Link to post
Share on other sites
Haiw    300

Lucky you... I have not regained any of the lost XP. Did receive XP on my first battle this morning, so there's a chance it could have been fixed? Or it could have been random... N = 1 after all.

Share this post


Link to post
Share on other sites
TyborPL    6

My progress was not recorded. Please investigate. (Checked again before a moment and it is still a thing)

MissionSession: 6097913380677257408, LoginSession: 7549913806446402750 

7f7a452beec1403b865d0e829aa5ec0b.jpg8924abb62d5845298ea39dd5e49d3cf2.jpg

Share this post


Link to post
Share on other sites
XaQtR    9

It's every soldier on my list that participates in a war battle which includes every vehicle and every weapon.  At the end of the battle I get the normal summary and all the ribbon XP and Rank XP is indicated but when I close the report, nothing is added to the soldier.  Staged matches seem to be fine for all my soldiers though.

 

I'm starting to think it's related to length of battle.  Just did a 13 minute war match and it was the first one (and the quickest) that actually counted and applied the Rank XP.

 

Nevermind.  Totally confused now.  Every war match so far has been ok.  long, short, win, lost, different soldiers.

Edited

Share this post


Link to post
Share on other sites
kacperkot12    1

Problems regarding not gaining EXP still persists but it seems to me that it's random and you sometimes get EXP and sometimes don't. I seemed to get EXP on this battle (5294477986385474741, LoginSession: 673718538042057548): 

1p30imY.jpg

But then in the next battle (MissionSession: 1832120307786303916, LoginSession: 673718538042057548) it reverted the majority of my EXP gain and I got this:

VZKYRJh.jpg

 

Edited

Share this post


Link to post
Share on other sites
Haiw    300

It's still hit or miss. My last one (33:49 game) registered just fine. That was MissionSession: 1247403613826157736, LoginSession: 4813015867532332844

The one before it didn't register at all (34:01 game). That was MissionSession: 488333105131364310, LoginSession: 4813015867532332844

 

So not sure about that time theory. Maybe it's just more noticable because the absence of the large amount of XP is more prominent.

Share this post


Link to post
Share on other sites

- Affected characters: all that I've played since patch 1.06 was installed and the 2 "hotfixes" since after the patch. (was there a 3rd hotfix a few hours ago?)

- Affected ribbons: all the ribbons that "rank up" glitch the progression (unsure about ribbons that did not rank up in the progress of the dozens of battles I've been in) BUT: purchased ribbon progression (gold or credits purchased) seem unaffected.

- Sorry no screenshots or battle IDs.

 

This has been going on since people started complaining about the medic badge not working. I noticed it at first when I ranked up my rank 3 tank crewman on the US side. ranked up to 4, but got negative experience, and haven't noticed ribbon XP...  Credits and warfunds seem unaffected by this bug/glitch (whatever you want to call it).

 

Hopefully more folks will have screenshots and battle IDs.

Share this post


Link to post
Share on other sites
Bamuh    25

Have not keept track of all chars and all gains. As it is quite an undertaking. But will try to do so.

 

But it seems to have affected all characters more or less since this 1.06. My "main" guy seems less affected than all the lower soldiers I am leveling up.

 

Will add info as found.

Share this post


Link to post
Share on other sites
Dudsworth    0

For me, I haven't noticed any lost ribbon experience.  What has happened to me though, is that both my Soviet Infantry and my German tanker have displayed a negative rank experience, and then after playing another battle I notice that they have been literally demoted in rank.    As in, my Soviet Infantry advanced to rank 2, but then after playing another match I go to their rank screen and they are rank 1 again.  This also happened to my German tanker.  I'm not playing the game again until this is fixed, considering it seems to be wiping out our progress.

Share this post


Link to post
Share on other sites
flakpanzer    224

Hehe it looks like if the Americans win this war they get no exp for the war victory ribbon... GG reto

Share this post


Link to post
Share on other sites
Judges    1

After three games grinding the Kar98 ribbon, looks to be resolved for me now, the GUI isn't showing the XP properly (I dont think it ever really has,) but it adds up after game which counts.

 

Don't think I'll get the two days of veteran back where I didn't play as a result of not getting XP most of the time, but my blood pressure is lower now.

Share this post


Link to post
Share on other sites
LittleDoggy    22

I have played with my soviet pilot character (Ilia Ilyushin). I don't have battle ID but anyway it was mountain town map against Germany. I was a heavy fighter and there was no enemy pilots. I hunted tanks and gained quite lots of xp for 'Tactical Bomber' and 'PetlyakovPe-3bis Specialist' ribbons. I even have unlocked silver 'Bombs Away' badge and it was equipped normally. But afterwards, ribbons weren't unlocked as displayed on the results screen, while the badge is still there.

 

I have screenshots but don't know how to upload here.

Edited
screenshots were not uploaded

Share this post


Link to post
Share on other sites
Echo0001    49

Seems to work again since the hotfix on friday.

But the days before all my characters were affected and all ribbons.

Btw didn't get the lost exp from the last days back... A Little bit unfortunate, as i though all games and battlereports must be saved somewhere and could be easiely solved to get back the lost ribbons... But at least it's woking now :)

Share this post


Link to post
Share on other sites
SK1M3R    1,288
On 4/6/2017 at 6:13 PM, SK1M3R said:

I have the same problem.

64u7R8W.png

TQMwJPE.png

8xJtgCg.png

and I did get a lot of XP in the last couple of battles so plz reto help me recover from this.

 

Share this post


Link to post
Share on other sites
conyn3496    15

- Affected character
Rank 15 Infantrist

- Affected ribbon(s)
Not getting any exp for shooting down para-planes. Did not look for ribbons.

- When a certain ribbon has been affected (f.e.x. tank destruction) please also note down which vehicle/weapon was used and with what ammotype.
I was using the Flak (AA) given by the map on O2. Shot down at least 5 para planes... did not get any exp for that.

- A screenshot of the scoreboard
Did not create one. Sorry. (Still having issues with game crashes since Engine Room Update... so "sorry".)

- BattleID

/M 3753668700557229703 /P 8810318638300466535 /W 37.48.111.80:15170

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.