Csarli59

Stuck at Anti-cheat enabled. Fetching your profile...

Recommended Posts

Csarli59    0

I want to play but it gets stuck at Anti-cheat enabled....  I opened the debugwindow and this is what I found:


[ Exceptions ] 2016-12-27 14:21:33.221 HeroesAndGeneralsDesktop. Uncaught exception:
[ Exceptions ] 2016-12-27 14:21:33.221 Buffer overflow while reading from shared byte array
Error: Buffer overflow while reading from shared byte array
 at com.google.protobuf::SharedByteArray$/readOverflowError()
 at com.google.protobuf::SharedByteArray$/newFromSharedByteArray()
 at dk.reto.heroesandgenerals.service::Chunk$/parseData()
 at dk.reto.heroesandgenerals.service::Chunk$/parseData()
 at dk.reto.heroesandgenerals.service::Chunk$/parseData()
 at dk.reto.heroesandgenerals.service::Chunk$/parseDataRaw()
 at dk.reto.heroesandgenerals.controller::HandleDownloadDataCommand/downloadTableCallback()
 at dk.reto.heroesandgenerals.service.helper::XMLService/dataReceived()
 at flash.events::EventDispatcher/dispatchEvent()
 at flash.net::URLLoader/onComplete()

I hope someone understands this. If yes, please tell me how can I fix this. :c
( The problem occurs in both Steam and Stand-alone version )
( And sorry for my English )

Share this post


Link to post
Share on other sites
xanax100mg    2

I still have the same issue. I opened the exact same thread on three different forums.

No answer.

 

I submitted a ticket already, provided the log files and such as well. Last response was on 22 December.

 

So yeah, I'd say either:

A. It's being worked on.

B. It's a such a rare problem so that it is being overlooked by the developers as if it never happened.

 

I'm not the type to speculate and create conspiracy theories, but the lack of information and a solution to this is yet to be provided.

Edited

Share this post


Link to post
Share on other sites
Csarli59    0

Yes, I have already tried that. I also tried restarting the router, trying both versions of the game and reinstalling it ( I verified the files after reinstalling it aswell ).

Share this post


Link to post
Share on other sites

Hi @Csarli59, @xanax100mg, Could you try the following thing? Go to your Heroes And Generals installation folder on your pc, Find, %APPDATA%, LocalLow and then
Delete Heroes and Generals folder. Run H&G Again it will then update and post if that worked for your problem.

 

if you search for %appdata%/../LocalLow/Heroes and Generals or paste it in the top bar it will get you there. 

Share this post


Link to post
Share on other sites
xanax100mg    2

Well, I followed your steps to delete that folder. However, not only it did not work, but also it failed to redownload that folder. 

 

Verified my files after to see if it downloads the folder, but it did not unfortunately. Thanks nevertheless for your attention to the issue @Astrolite.

Share this post


Link to post
Share on other sites
46 minutes ago, xanax100mg said:

Well, I followed your steps to delete that folder. However, not only it did not work, but also it failed to redownload that folder. 

 

Verified my files after to see if it downloads the folder, but it did not unfortunately. Thanks nevertheless for your attention to the issue @Astrolite.

 

33 minutes ago, Csarli59 said:

I did the exact same thing but nothing. :c

 

Hmmzz.. :( i hope you guys can be a little bit more patient. The Developers are on it to work out a solution. Unfortunatly the server sends the wrong file(s) back to you guys for some reason. They are trying to figure out the problem and on wich server(s) this happends and why this happends. 

 

Just wanted to let you guys know that Reto is on it :) 

Share this post


Link to post
Share on other sites
xanax100mg    2

As of now, I am able to sign in and play. I had not changed anything yet H&N Sync managed to download some files. Thanks a lot for your attention both Reto members and community helpers such as @Astrolite.

Share this post


Link to post
Share on other sites
Csarli59    0

Good for you, I still have the same problem. I hope they will be able to fix it soon. :(

Share this post


Link to post
Share on other sites
5 minutes ago, Csarli59 said:

I did what you said but I still have the same issue. :/

Okay.. Well it was worth it trying tho.. Anyway Reto is on it and tries to solve the problem as soon as possible ^^ 

Share this post


Link to post
Share on other sites
Hammerite    40

Reto sure cares a lot for player problems.

btw. Any ... Software running that produces an overlay? My game loves to stuck and Fake-Anti-Cheat loading when MSI Afterburner is on for some magic reasons. Maybe u have some similar problem ?

Share this post


Link to post
Share on other sites