_Yank

[Solution] Stuck in game loading and/or display driver crash

Recommended Posts

_Yank    1

[SOLUTION] STUCK IN GAME LOADING AND/OR DISPLAY DRIVER CRASH

Follow the steps below.

 

Press the windows and R key (it pops out the Run dialog) and type regedit (to open the Registry Editor). Then you go to the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers directory, right click on the right panel, Go to New and then Dword (to create a new value). Named it TdrDelay then right click it, press on Modify, write 30 and hit Ok. Then go to the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\DCI directory (just inside the previous one) and do the same thing you did in the previous directory but this time name the value it as Timeout. Then, reboot the machine and BOOM, you can play this game again! The game is now loading and working just fine, no more 10 FPS shizzle, 60FPS out of the box!

 

Why does this happen ?

 

Well it is quite hard to explain, will try to give a soft, not-so-accurate explanation… Since Vista, Windows implemented a "system" to automatically restart the GPU driver in case of failure to avoid BSODs and similar errors that may need the computer to restart to get the GPU completly working again (in this case, it would automatically restart the GPU driver if the GPU took more than 2 seconds to render 1 frame.). As this game is still in beta, there’s some things still need to be optimized and the game loading is probably one of these things, it probably tries to load too much things at once or there’s a code leak and it makes your GPU hang, passing the 2 seconds mark.

 

What does the fix do ?

 

It increases the timeout of the automatic gpu restart that is mentioned above from 2 seconds to 48. Anyway you should consider this as a workarround and as soon as this is fixed in the game you should delete that 2 values you created on the registry editor.

 

~Astrolite

Edited
Edit font fix

Share this post


Link to post
Share on other sites
-HoHoHO-    30

I am already in the Registry Editor. I didn't knew there is something like that on my Laptop.

I hope it will not explode after all :?

Share this post


Link to post
Share on other sites
_Yank    1

Don't be worried it isn't something dangerous (if you be careful and do exactly what I did). Tell me your results though.

Share this post


Link to post
Share on other sites
-HoHoHO-    30

It didn't worked for me. The game crashes even more and often directly on the start of the match.

Maybe because I use ATI.

maybe also, i did not understood this part?

and did the same thing I did in the previous directory but this time named the value it as Timeout.

shall I do just the same in both directorys, or not? :D

Share this post


Link to post
Share on other sites
_Yank    1

Yeah you should do the same thing but instead of naming it as TdrDelay, name it as Timeout, otherwise it will not work.

Share this post


Link to post
Share on other sites
-HoHoHO-    30
Yeah you should do the same thing but instead of naming it as TdrDelay, name it as Timeout, otherwise it will not work.

In DCI there is already one REG_DWORD named "Timeout". Its value is =7

I can't add one more Timeout value so I change the existing one to 30.

l8er

Share this post


Link to post
Share on other sites
-HoHoHO-    30

OK

This seem to work because the game behaves different. I have good FPS and in one game no crash and no stuttering but it doesn't solves the problem of that famous hotfix. In game I still expierience long freezes, sometimes one after another, caused by same situations: when lot of players are around, vehicles/bullets/projectiles passing by, the reloading animation and loadind of textures and so on, it is eating the memory and crying for more. OK, at some point all freezes end without game crash because of those increased tolerance values, still due to those long freezes the game remains inacceptable for me atm...

maybe for someone with faster PC it will work better. The rumor may be spread, it seems to work. good job

Share this post


Link to post
Share on other sites
Mark_Ripley    2

Didn't help in my case... instead of being stuck at 0%, now the loading bar gets stuck at about 75%. The game is unplayable for me since Reto's last hardware upgrade/server down (Furness update and hotfix still worked fine). I already reinstalled and changed from steam to browser. Had no effect. I didn't change anything concerning software or hardware on my rig. Frustrating :(

Share this post


Link to post
Share on other sites
Didn't help in my case... instead of being stuck at 0%, now the loading bar gets stuck at about 75%. The game is unplayable for me since Reto's last hardware upgrade/server down (Furness update and hotfix still worked fine). I already reinstalled and changed from steam to browser. Had no effect. I didn't change anything concerning software or hardware on my rig. Frustrating :(

TIP: Play trough browser (Firefox)) --> Make sure your ports are allowed the games connection and no programs in the back ground interfering with the game. Aswell as haveing an uptodate flash plugin.

Share this post


Link to post
Share on other sites
Mark_Ripley    2
Didn't help in my case... instead of being stuck at 0%, now the loading bar gets stuck at about 75%. The game is unplayable for me since Reto's last hardware upgrade/server down (Furness update and hotfix still worked fine). I already reinstalled and changed from steam to browser. Had no effect. I didn't change anything concerning software or hardware on my rig. Frustrating :(

TIP: Play trough browser (Firefox) ;) Make sure your ports are allowed the games connection and no programs in the back ground interfering with the game. Aswell as haveing an uptodate flash plugin.

Thx, but I already covered those things in my trouble-shooting. It has something to do with the graphics driver. I tried it with the latest driver version as well as the previous and an even older one (clean install every time). It had no effect. My card works fine (GTX 850m) since every other game or program can use it.

Matches actually load and start if I switch to Intel graphics instead of Nvidia card in the Nvidia control panel! Sadly, I only get about 12 FPS with Intel graphics...

The issue seems to affect some other people as well cause it's discussed in various threads:

http://forum.heroesandgenerals.com/viewtopic.php?f=87&t=83383

Still, you did a great job explaining this workaround, Astrolite. Looks like it really worked out for a few people. I just expect Reto to take care of those issues in the first place. It can't be that we are forced to use workarounds and console commands etc. to tweak this game in order to make it playable on standard rigs :!:

Share this post


Link to post
Share on other sites
Slyder73    0

I tried the registry workaround the other day and it did not help for me.

Still unable to play as of last Saturday.

Share this post


Link to post
Share on other sites
Slyder73    0

The forum update has made this thread a bit confusing and the quotes are not showing up.

Has anyone actually been able to get the game working again from the "action game not loading" issue?

I did the registry workaround (along with every other troubleshooting strategy I could think of and others suggested on the handful of threads on this issue). No luck with any of them, nor with the registry workaround.

I have a support ticket in and they suggested deleting the localfiles.ini file, which did not help either. I've not heard back from support about the issue again yet and hoping to soon.

Has anyone tried anything else that has fixed issue with the action game not loading?

It has been a week now and I'd love to get to play again!

Share this post


Link to post
Share on other sites
Slyder73    0

Same here. I am still unable to play the Steam version of the action game.

I did load the game through the Firefox browser and have been playing that way, so at least the browser version works, with a few extra steps.

Would be nice for the Steam side to be fixed though.

Share this post


Link to post
Share on other sites
Slyder73    0

The extra steps: The desktop icon does not work. I have to open Firefox, go to the bookmark of this site, and actually click on the "Play Now" icon on the bottom of the screen. The browser frame also shows when in character and Generals screen, which is mostly cosmetic but still irritates me.

If Steam worked, it is a simple icon click and everything worked fine until the Steam version stopped working. Thus a few extra steps. Piddly I know, but I am picky.

Just an FYI for devs or bug hunters; the Firefox browser version creates a desktop icon. A plugin is required for the browser, which I installed. The game works fine if I navigate to "here" and click on the "Play Now" at the bottom. If I click on the desktop icon, it will not start, giving me the message that I need to install the plugin.

Still not working in Steam though.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.