EasiestNine0

NVIDIA Settings to Help Stabilize FPS

Recommended Posts

To understand the importance of my post, here is a short recap:

 

1) Before Bauer update : very playable, no graphical lag, though about 40 FPS.

2) After Bauer update (I had stopped playing a month) : FPS fell to 14 (19 with everything low) and was very laggy. Everything seemed shadowy and heavy.

3) Fixed back up to 40 to 80 FPS after fiddling with my NVIDIA Control Panel settings.

 

I believe, from reading about some who have low FPS with powerful gaming rigs, and from my current experience, that there is a glitch or graphics conflict that explains why some have horrible FPS even with a 2010+ GPU. It may have little to do with the Bauer update, and simply be a conflict with my NVIDIA Control Panel settings this last month before coming back to H&G.

 

Guide to tweaking NVIDIA GPU settings (free, very well written and you can tell reading a paragraph or two that the author really knows his tech)

nb: sent to H&G Support in case it helps debug the probable graphical conflict.

Share this post


Link to post
Share on other sites
berd0    1

Intel HD graphics masterrace!

[ Post made via Android ] Android.png

Share this post


Link to post
Share on other sites
alupkasix    415
IS vsync dropping fps or not?

Vsync basically lowers your FPS to your monitors refresh rate to prevent screen tearing.

If you don't reach that or around that, then there is no point of it turned on.

[ Post made via Android ] Android.png

But I think also if your PC can't get 60 fps with vsync, it will automatically readjust to 30, and then 15 and so on. So even without tearing issues, it could still help to stabilize the game.

Also, while in nVidia control panel, you can check the "configure surround, physx" under 3D settings, and make sure physx is being processed by your video card instead of CPU or Auto. I think Auto basically leaves the decision up to the game developers, but since not everyone has video cards, developers could be inclined to choose CPU (less performance, but more universal).

If you have nVidia, it may help to manually specify this, basically telling nVidia, hey this is your job...do it.

Share this post


Link to post
Share on other sites
Tykjen    47
IS vsync dropping fps or not?

Vsync basically lowers your FPS to your monitors refresh rate to prevent screen tearing.

If you don't reach that or around that, then there is no point of it turned on.

[ Post made via Android ] Android.png

But I think also if your PC can't get 60 fps with vsync, it will automatically readjust to 30, and then 15 and so on. So even without tearing issues, it could still help to stabilize the game.

Also, while in nVidia control panel, you can check the "configure surround, physx" under 3D settings, and make sure physx is being processed by your video card instead of CPU or Auto. I think Auto basically leaves the decision up to the game developers, but since not everyone has video cards, developers could be inclined to choose CPU (less performance, but more universal).

If you have nVidia, it may help to manually specify this, basically telling nVidia, hey this is your job...do it.

Turn off everything in nvidia panel that says vsync, adapted vsync. and ofcourse turn off vsync ingame. adapted vsync is something of the worst.

Share this post


Link to post
Share on other sites
alupkasix    415
Turn off everything in nvidia panel that says vsync, adapted vsync. and ofcourse turn off vsync ingame. adapted vsync is something of the worst.

I understand where you're coming from but to clarify:

I'm guessing, like me, you have decent hardware and don't need vsync.

i7-4790k at 4.6GHz; GTX 970 FTW; 5 second boot time

But my coworkers and I have tested some lower end AMD computers with multiple configurations and found that vsync enabled helped on those particular machines.

So I think the right answer is somewhat dependent on the machine.

I don't suggest everyone to use vsync...I suggest to those who are having related issues to try both and see which one works better for them. If it doesn't help, turn it off. Likewise; if it's enabled already and you have issues, try disabling it.

Lastly, don't expect it to solve all of your problems in any case; obviously one nVidia setting won't turn a crappy laptop into a custom gaming rig.

Share this post


Link to post
Share on other sites
BurnoutDV    56

While the particular settings hadnt a large effect this thread made me realize something..my stupid laptop uses the integrated graphic card by default which explains the 7 FPs i have on this thing...meh

Share this post


Link to post
Share on other sites
Tykjen    47

Lastly, don't expect it to solve all of your problems in any case; obviously one nVidia setting won't turn a crappy laptop into a custom gaming rig.

Yes it can. On laptops especially. Ive lost count over how many laptops Ive fixed where I had to change an AMD or NVIDIA setting to make the laptop use the proper GPU and not the uber slow integrated. And then theres the power settings as well. Set all power to maximum performance and turn off all automatic throttling on cpu.

While the particular settings hadnt a large effect this thread made me realize something..my stupid laptop uses the integrated graphic card by default which explains the 7 FPs i have on this thing...meh

oh hey speak of the Devil.

Share this post


Link to post
Share on other sites
alupkasix    415

Lastly, don't expect it to solve all of your problems in any case; obviously one nVidia setting won't turn a crappy laptop into a custom gaming rig.

Yes it can. On laptops especially. Ive lost count over how many laptops Ive fixed where I had to change an AMD or NVIDIA setting to make the laptop use the proper GPU and not the uber slow integrated. And then theres the power settings as well. Set all power to maximum performance and turn off all automatic throttling on cpu.

While the particular settings hadnt a large effect this thread made me realize something..my stupid laptop uses the integrated graphic card by default which explains the 7 FPs i have on this thing...meh

oh hey speak of the Devil.

All true. Tweaking settings can definitely improve performance.

You may have misunderstood my meaning. My point was that a setting can't make a laptop that only has cheap integrated video perform like a custom PC with high-end dedicated graphics card.

I was making the point because I've seen threads (not just H&G) where people were wondering how to get their computers to perform like someone else's, without realizing the hardware between the two were in completely different classes.

In those situations, there is simply no way to accomplish the task by tweaking settings.

Furthermore, my point wasn't directed at you or the OP or anyone tech savvy, it was intended for those reading that aren't familiar with computers.

I'm sure you've seen some of the threads here complaining about gaming performance only to later disclose they're playing on a $300 laptop. ;)

Share this post


Link to post
Share on other sites
Siriel    11

To understand the importance of my post, here is a short recap:

1) Before Bauer update : very playable, no graphical lag, though about 40 FPS.

2) After Bauer update (I had stopped playing a month) : FPS fell to 14 (19 with everything low) and was very laggy. Everything seemed shadowy and heavy.

3) Fixed back up to 40 to 80 FPS after fiddling with my NVIDIA Control Panel settings.

I believe, from reading about some who have low FPS with powerful gaming rigs, and from my current experience, that there is a glitch or graphics conflict that explains why some have horrible FPS even with a 2010+ GPU. It may have little to do with the Bauer update, and simply be a conflict with my NVIDIA Control Panel settings this last month before coming back to H&G.

Here are my NVIDIA settings that work well now :

Object Quality[/i] with the rest low (the game will save this only if you begin with general High Quality and reduce by hand after).

[attachment=0]Heroes-Generals-settings_that_work.png[/attachment]

Specs (for Devs) : using Steam / NVIDIA GeForce GTX 650 / i7 2600S (3.80 GHz) in ASRock B75M-GL / Windows 10 Pro.

Guide to tweaking NVIDIA GPU settings (free, very well written and you can tell reading a paragraph or two that the author really knows his tech)

nb: sent to H&G Support in case it helps debug the probable graphical conflict.

Share this post


Link to post
Share on other sites
bocaz    682

i will try =)

I get fps drops now, after i updated the drivers, everytime i minimize.

Also i had to reduce the resolution.. no longer a stable 30 to 40 fps :\

Share this post


Link to post
Share on other sites
alupkasix    415
To understand the importance of my post, here is a short recap:

Thanks for clarification and details.

I hope to have time this week to test it out.

Share this post


Link to post
Share on other sites
Siriel    11

Also note that Support wrote to me that the newest NVIDIA driver seems to have conflicts with the game (which would be 364.47, March 8, 2016).

I responded though that, in my case with these settings and with those new drivers, it fixed the graphical issue I had (game was excessively shadowy with horrible FPS 14 to 19).

EDIT: I turned HDR back on : little impact on FPS and makes the game environment less dark.

Share this post


Link to post
Share on other sites
lastverb    0

Messing with control panel doesn't increase fps for me, hell even trying to set hng to run under integrated card doesn't work (diode shows that something IS using dedicated gpu), which is very strange behaviour.

Even tried running everything (including system) under dedicated. Practically kills the game for me. 15 fps in FPS is unplayable. Same laptop gets more fps in Witcher 3 at max settings than on lowest in hng.

edit: the thing that fixed it was uninstalling the game and installing it by steam, now I just have "game loading" screen for like 2mins instead of seconds, but the game works fine with ~70 fps. Oh and like 20% of those game loadings ends with "failed to lookup players profile".

Share this post


Link to post
Share on other sites
pakkux    0

I setuped physx to be used by gpu but when I went ingame the physx was still using cpu. Is this driver problem?

Share this post


Link to post
Share on other sites
RZ2000    1,026

Here is a good trick for smooth gameplay, higher FPS is far better

V-sync LAGS your computer to render a frame after a request, so it lags

Limiting FPS is even worse

When your monitor refreshes, it looks at the last rendered frame to display, so giving it more options (more FPS) is the best for smooth gameplay. If you don't believe me, play any low spec game at 60 FPS, then try to max it out, it feels better even if refresh rate is the same

Share this post


Link to post
Share on other sites