CMG0729

Very low fps! How it's possible?

Recommended Posts

CMG0729    0

Hey guys, I'm gonna start off by saying I'm using the browser version through Chrome. Since my monitor is only 60hz, I always aim for 60 FPS(which I am getting in this game for the most part) and I am pretty certain my pc should not have problems achieving that in any scenario. I have tried tweaking the game settings, AMD control panel settings and lately I have overclocked both my CPU and GPU, but that didn't seem to give me any FPS increase at all, so I started paying closer attention to the CPU and GPU load.

So I get into this foggy town map, and I get pretty stable 60 FPS when running between buildings in the alleys, but then I found a pretty good spot just outside the church where it dropped to 40 and decided to take a look at what my pc is doing;

http://i.imgur.com/sahVYEO.jpg

So, my radeon hd6850 was at around 75% load, so it doesn't seem to be bottlenecking anything. Temperature is fine, that's not the issue. However, lowering the resolution from 1920x1080 to 800x60 give me the same FPS and gpu load goes down. So it looks like my CPU has an issue, but it's not being bottlenecked.

CPU average load between all cores 50-55%. It's getting enough voltage, it's stable and it was 53C at the time. It's just not being utilized.

8GB RAM, nowhere near close to being capped.

So, is the game itself not able to catch up, or is it something I could be missing about my pc? If I am getting 40FPS in this particular scenario, when my pc is ~65% utilized, what do you think I could try next?

By all means, this is not a rant. I am just an FPS player who is used to always having 60+ FPS and I really value my framerate in FPS games, especially when you are in an important war game storming an objective. The difference between 60 and 40 fps is very noticeable and it annoys me when I am at a disadvantage because of something I can't figure out. Also weird thing I noticed, the framerate seems to gradually get lower and lower as the game goes on.

Almost forgot, running Windows 7 64bit and I also attached my dxdiag.

Share this post


Link to post
Share on other sites

How low is your fps ?

Did you try update your drivers. Turn off everything you can in game ? :)

I got the same processor and the stragegy map eats 30-40 % of it so try and put that on assault teams or character.

But it should be better whit the next major update

Internet connection dosent have any effect on fps :)

Share this post


Link to post
Share on other sites
RWG209    0

Hi everyone!

I just begun playing at this promising game two days ago and I'm getting the same problem as banan1025: very low FSP rate in the first person mode.

I play with a Notebook Acer Aspire 5755G-7678G1TMnks:

CPU i7-2670M

8Gb RAM,

Graphic card Nvidia GeForce GT 630M 2Gb

During the game I get 13 FPS if I'm alone and only 9 FPS when there's someone around. This statistics are with all graphic options set to low apart from graphic quality: I keep it high or I just can't see the enemy.

I play the RTS game using Google Chrome.

Another little issue is that my graphic configuration is not saved: every time i login in a battle i have to set fullscreen to "on" and terrain details to "low", 'cause i get them always high and in windowed mode. Is it normal? Are you guys having the same issues?

Thank you! :)

Share this post


Link to post
Share on other sites

Yeah it doesn't save Terrain and it always starts in windowed mode. First thing I do when the game finishes loading is go into the options and fix the graphics so they are all low or off (and you can maximize the window by hitting Alt+Enter). If I'm joining a game with a high ping is it is really slow until I turn down the terrain (like I can't even click through the spawn menu). But once I have everything on the lowest settings and turned off everything unnecessary and mine is running fine. I hit lag everyonce in a while but I'm not sure why yours would always be low.

Share this post


Link to post
Share on other sites

Same issue here, no real reason even with all graphics settings turned low/off I get what I can only guess is about 10 frames per second, if I'm lucky. Not sure what in the world I have to do to make this game run.

Using the latest version of Firefox. Windows 7 Pro 64 bit, intel core 2 duo e8400 @ 3ghz, 6gb of ram, evga GTX 560 Ti ... what more does it want?

Share this post


Link to post
Share on other sites
Neonidos    0

The game doesn't really currently save any graphics configurations; as far as I know, that's a known bug.

Do you check your FPS versus Ping with F7? Post those results; I have a feeling it has more to do with your ping than it does with your computer. I have a fairly decent machine, and on high-graphics the game becomes a buggy mess of graphics, but on default mode I easily pull 70 FPS.

Also, your browser isn't going to affect your first-person shooter game; that's client-based. Chrome has a faster campaign map, but some of the things that make FireFox so slow - like the fires - are going to be removed or modified to make it more responsive. Also, ping issues are being addressed.

Share this post


Link to post
Share on other sites
hobu8    0

I have as the baron around 70 fps in the normal game, but when i aim down the sight of my weapon i often recognize that my fps drop below 30 what makes aiming sometimes horribly annoying :|

i think i have read this somewhere before, idk for sure, just wanted to mention it. :mrgreen:

Share this post


Link to post
Share on other sites
Spiritflask    1
I have as the baron around 70 fps in the normal game, but when i aim down the sight of my weapon i often recognize that my fps drop below 30 what makes aiming sometimes horribly annoying :|

i think i have read this somewhere before, idk for sure, just wanted to mention it. :mrgreen:

I always play in Low settings with 20 fps 8-) ;)

Share this post


Link to post
Share on other sites
niels5834    0

The airfield map can get very ugly - normaly i had around 50 fps with aiming dropping around 30-35, but on the Airfield map, when aiming i hit the verry bottom going to 12-15 fps, which makes it unplayable, so i was using only hip fire there. This was with my 4850. Now i got my new 7850 VC and no map can get me lower than 50fps when aiming down the sight xD

Share this post


Link to post
Share on other sites
Hi everyone!

I just begun playing at this promising game two days ago and I'm getting the same problem as banan1025: very low FSP rate in the first person mode.

I play with a Notebook Acer Aspire 5755G-7678G1TMnks:

CPU i7-2670M

8Gb RAM,

Graphic card Nvidia GeForce GT 630M 2Gb

During the game I get 13 FPS if I'm alone and only 9 FPS when there's someone around. This statistics are with all graphic options set to low apart from graphic quality: I keep it high or I just can't see the enemy.

I play the RTS game using Google Chrome.

Another little issue is that my graphic configuration is not saved: every time i login in a battle i have to set fullscreen to "on" and terrain details to "low", 'cause i get them always high and in windowed mode. Is it normal? Are you guys having the same issues?

Thank you! :)

same problems here!! :((

Share this post


Link to post
Share on other sites
nizcue    0

Maybe I found the cause oh this problem:

Wneh I click with the right button of the mouse on the game icon and I put the cursor on the section about the graphic processor, it says that the integrated graphic card is set as default graphic processor instead of the nvidia processor...The problem is, when I try to click on the Nvidia graphic processor to set it as the default processor to run the game, it doesn't work!

Can you check if I'm right?

-thank you and sorry for my bad english...I hope you'll understand what I wrote :)

Share this post


Link to post
Share on other sites
dra6o0n    7

Must mean that this game somehow wants to render the game with solely CPU.

Are you sure that they are using the correct library to develop this game, like using OpenGL or something to help the rendering ease it's resource intensive tasks?

A i5 2500 is more than enough for the game, and with a GTX 550 ti that can run a BF3 on medium-high graphics, I find that it's silly that I play with a 40fps on low graphical levels with hdr on on a 1600x1050 resolution roughtly.

The issue seems to have to do with fog and long distance rendering, since when you use iron sights to the distance, the frame rate drops by 10~15 fps.

This means that either high cpu usage is needed, or the game is very un-optimized regarding long distance rendering...

Also another question, do you render long distanced trees and objects as sprites other than actual 3d models? You can ease up on the resource use if you have 3d models vanish and replaced with 2d sprites. Long distance as in 300M away the trees will not render but show 2d sprites instead. So using binoculars won't make them render into 3d and bog down the graphics.

Also, fog DOES NOT save frame rates since it is still rendering the stuff behind it.

You can only make fog render more efficiently if stuff hidden in it isn't rendered to save resources.

EDIT: Fog as a alpha map that changes transparency also eats up GPU in a sense... If you use fog as a mean of using partial effects, you are basically lagging everyone's system with unneeded visual coverage.

One should always do research to see how other indies work on their games so you can get ideas on efficient development. I see most of this tech thanks to wolfire games and their weekly alpha videos, and some from natural selection 2 when I saw a video stream of them editing the game.

Share this post


Link to post
Share on other sites
hetanne    0

I play the game on the lowest settings. I should be able to at least play the game on medium but somehow i only get 8 fps on medium and 20 fps on low? I can't even imagine how this is possible.

System:

Windows 7 64 Bit

Processor: Intel® Core™ i7-2670QM CPU @ 2.20GHz (8 CPUs), ~2.2GHz

Memory: 8192MB RAM

Available OS Memory: 8086MB RAM

Nvidia GeFore GT 730M

Current Mode: 1920 x 1080 (32 bit) (60Hz)

Share this post


Link to post
Share on other sites
Guest Guest   
Guest Guest

3GB ram not enough , you need 4-8 and 64-bit .

The game runs 3GB flat memory somtimes , that + you OS and other stuff ;). Do the math

Share this post


Link to post
Share on other sites
Madbox    0

I had the same problem, it's just that the game uses your intel HD chipset instead of your graphic card. So, you need to add the game in your nvidia configuration panel and select your graphic card.

Share this post


Link to post
Share on other sites
zerov25    0
I have as the baron around 70 fps in the normal game, but when i aim down the sight of my weapon i often recognize that my fps drop below 30 what makes aiming sometimes horribly annoying :|

i think i have read this somewhere before, idk for sure, just wanted to mention it. :mrgreen:

wish I had 30fps when that happen, I play with 20 fps +/- and I have places where I zoom (binoculars and scoped) and I go to 14 fps

Share this post


Link to post
Share on other sites
pikpaint    0

I also have low-fps problems.

I've got pretty new (two weeks)laptop configured as follows:

Intel i7 3610QM 2.4GHz@3.2Ghz 8CPU

GeForce 660GT

8 GB RAM @ 1600MHz

Resolution HD, 1366x768

Windows 8, newest possible drivers

Crysis3, FarCry3, Dead Space3 (much of those threes this year...), World of Tanks, Planetside 2 running on high/ultra configurations, so I turned in-game specifications to highest possible as well. Unfortunately, I was unable to play, thanks to ultra-low fps. Turning to medium also didn't helped much. Didn't had time yet to try some superlow configuration, but I think this is not very good in terms of optimalization. Does Devs are working on that, or "is it working as intended"?:) Frankly speaking, game does not look astonishing (yet?), so specification requirements should not by so high in my opinion...

Share this post


Link to post
Share on other sites

hi every one.i had the same problem in FPS.but i finaly fix it. plz all attention :

1.first close the game then open nvidia panel go to manage 3D settings.click the add bottem.browes the game directory in the root file . my game.exe was in C:\programfile(86x)\heroes & general\hng.exe >> add this to the panel.then set the prefered graphics processor to high-perfomance.then apply

2.go to your game diractory open file dirctx setup it.remember u have to setup this directx from your game diractory it has some thing for this game.just this game !

then these step u can go to the combat :x with a high fps

i try it and it is working 100% percent !

thx all . sory for my bad engilish ;)

Share this post


Link to post
Share on other sites